Comment

Comment by inopinatus

To this day I maintain that a large part of IPv4 space wastage is due to the HTTP WG's longtime avoidance of adopting SRV or SRV-like DNS records or even the DNS itself as normative for HTTP/HTTPS, instead allowing the HTTP RFCs to just vaguely suggest that DNS might be one way to resolve the IP address of origin servers, whilst in practice squatting on the A (address) record like they owned it (and worse, all the apex records). Consequently inspiring a vast chorus of LIRs applying for /19 allocations over the years "for SSL hosting" and continuing to do so long past the introduction of SNI (RFC 3546). Saw this behaviour firsthand as a European LIR operator with friends at RIPE. Is it cracked down on now? Yes. Are there whole swathes of IPv4 space that remain unassigned or entirely unannounced? Yes. Does every large-scale DNS hosting service have some hackish way to workaround the prohibition of CNAME records at the zone apex? They sure do, and HTTP is why.

Paul Vixie saw it coming, the very first example in the original SRV proposal (RFC 2052, 1996) is resolution of HTTP. Alas that this example was omitted in later editions. The new SVCB/HTTPS RRs (RFC 9460, 2024) are literally decades overdue.

parent inopinatus 2 years ago

Discussion

Live from the official Hacker News API

A modern reader for Hacker News · SvelteKit + Skeleton